package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{Arabic}\s\p{N}]+$`)
var str = `الإجراء المطلوب عزيزى المورد تمت الموافقة على اتفاقية شراء عامة جديد رقم `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}