re = /^[\p{Arabic}\s\p{N}]+$/m
str = 'الإجراء المطلوب عزيزى المورد تمت الموافقة على اتفاقية شراء عامة جديد رقم '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end