package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^0-9]+)`)
var str = `sdfsadf2348953984160ch18129347@#^&*()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}