$re = '/([^0-9]+)/m';
$str = 'sdfsadf2348953984160ch18129347@#^&*()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);