re = /^(.*?):$\n"(.*?) (.*?)$\n(.*?) (.*? .*?) (.*?)$/m
str = 'sample.txt:
"government high school
Govt high school physics department
Employee Designation School Assistant"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end