package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^-\s][a-zA-Z\sàèìòùÀÈÌÒÙáéíóúýÁÉÍÓÚÝâêîôûÂÊÎÔÛãñõÃÑÕäëïöüÿÄËÏÖÜŸçÇߨøÅ寿œ\d!@#$\+%&\'*]{1,20}`)
var str = `Collection '98`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}