re = /[^-\s][a-zA-Z\sàèìòùÀÈÌÒÙáéíóúýÁÉÍÓÚÝâêîôûÂÊÎÔÛãñõÃÑÕäëïöüÿÄËÏÖÜŸçÇߨøÅ寿œ\d!@#$\+%&\'*]{1,20}/m
str = 'Collection \'98'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end