#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!pet).)*$"
Local $sString = ""/pet"," & @CRLF & _
""/pet/findByStatus"," & @CRLF & _
""/pet/findByTags"," & @CRLF & _
""/pet/{petId}"," & @CRLF & _
""/pet/{petId}/uploadImage"," & @CRLF & _
""/store/inventory"," & @CRLF & _
""/store/order"," & @CRLF & _
""/store/order/{orderId}"," & @CRLF & _
""/user"," & @CRLF & _
""/user/createWithArray"," & @CRLF & _
""/user/createWithList"," & @CRLF & _
""/user/login"," & @CRLF & _
""/user/logout"," & @CRLF & _
""/user/{username}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")