import re
regex = re.compile(r"^((?!pet).)*$", flags=re.MULTILINE)
test_str = ("\"/pet\",\n"
"\"/pet/findByStatus\",\n"
"\"/pet/findByTags\",\n"
"\"/pet/{petId}\",\n"
"\"/pet/{petId}/uploadImage\",\n"
"\"/store/inventory\",\n"
"\"/store/order\",\n"
"\"/store/order/{orderId}\",\n"
"\"/user\",\n"
"\"/user/createWithArray\",\n"
"\"/user/createWithList\",\n"
"\"/user/login\",\n"
"\"/user/logout\",\n"
"\"/user/{username}\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")