import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\brv(?:\\s{1,100}\\w{1,100}){3,5}\\s{1,100})\\bmild to moderate\\b";
final String string = "enlarged lv chamber with some degree of mild to moderate systolic dysfunction\n"
+ "enlarged rv chamber with some degree of mild to moderate systolic dysfunction";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}