re = /(?<!\brv(?:\s{1,100}\w{1,100}){3,5}\s{1,100})\bmild to moderate\b/m
str = 'enlarged lv chamber with some degree of mild to moderate systolic dysfunction
enlarged rv chamber with some degree of mild to moderate systolic dysfunction'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end