import re
regex = re.compile(r"^(?![0]\b)\d+\.", flags=re.MULTILINE)
test_str = ("any\n"
"10.0.0.1\n"
"0.0.0.255\n"
"22\n"
"telnet\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")