using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?\n(?=Paragraph)";
string substitution = @"";
string input = @"Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date
From: One line of text To: One or more lines Subject: One or more lines References: One or more lines
From: One line of text To: One
or
more
lines Subject: One or more lines References: One or more lines
From: One line of text To: One or more lines Subject: No references.
From: One line of text To: One or more lines Subject: One
or
more
lines
References: One or more lines
Paragraph 1 Title: A paragraph
Paragraph 2 Title: Another paragraph";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}