re = /(?:[\(\)eA-Z][a-z]*(?:_\{? ?\d*\}?(?:(?:_\d)?)*)?)+(?:\^\{? ?\d*[\+-]?\}?)?/
str = '(NO_3)_{2} + (SO_4)_{21}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end