package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Z]{3,5}\b`)
var str = `XYZ was seen at WXYZ with VWXYZ and did ABCDEFGH.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}