$re = '/\b[A-Z]{3,5}\b/';
$str = 'XYZ was seen at WXYZ with VWXYZ and did ABCDEFGH.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);