const regex = /^([A-z][0-9]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-z][0-9]+)$', 'gm')
const str = `N00044
n0
n09
n099
AS2
Nf2
nf_2
nf 08
n09 0
N 0009
N000a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}