$re = '/^([A-z][0-9]+)$/m';
$str = 'N00044
n0
n09
n099
AS2
Nf2
nf_2
nf 08
n09 0
N 0009
N000a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);