import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cat(?![^<]*>|[^<>]*<\\/mux-video>|[^\"'<>]*href\\s*=\\s*['\"][^'\"]*['\"])";
final String string = "text with a cat\n"
+ "<img src=\"path/to/cat.jpg\" />\n"
+ "<mux-video source=\"path/to/cat\">cat</mux-video>\n"
+ "more text with capital Cat CAT cAT\n"
+ "<a href=\"path/to/cat.pdf\">this should match cat</a>\n"
+ "works!\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}