const regex = /cat(?![^<]*>|[^<>]*<\/mux-video>|[^"'<>]*href\s*=\s*['"][^'"]*['"])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('cat(?![^<]*>|[^<>]*<\\\/mux-video>|[^"\'<>]*href\\s*=\\s*[\'"][^\'"]*[\'"])', 'gi')
const str = `text with a cat
<img src="path/to/cat.jpg" />
<mux-video source="path/to/cat">cat</mux-video>
more text with capital Cat CAT cAT
<a href="path/to/cat.pdf">this should match cat</a>
works!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}