package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:<\d{1,3}>)\s*([^[]+?)(?:\[\d*\])?:(.*)`)
var str = `<103>CP-MGMT xpand[2859]: Configuration changed from localhost by user admin by the service dbset
<31>routed[4006]: rt_instance_monitor_job: scheduled next instance monitor in 5 seconds
<134>CP_FireWall: 2Jul2017 18:52:23 accept ip address message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}