re = /(?:<\d{1,3}>)\s*([^[]+?)(?:\[\d*\])?:(.*)/m
str = '<103>CP-MGMT xpand[2859]: Configuration changed from localhost by user admin by the service dbset
<31>routed[4006]: rt_instance_monitor_job: scheduled next instance monitor in 5 seconds
<134>CP_FireWall: 2Jul2017 18:52:23 accept ip address message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end