use strict;
my $str = ' - Item: Oldman\'s_Romance
Rate: 50
- Item: Grasshopper\'s_Leg
Rate: 8000
- Item: Azure_Jewel
Rate: 9000
- Item: Grasshopper_Doll
Rate: 1500
- Item: Angel\'s_Arrival
Rate: 1000
- Item: Center_Potion
Rate: 700
- Item: Angel\'s_Departure
Rate: 10600
- Item: Left_Potion
Rate: 23471
- Item: Right_Potion
aRate: 6000';
my $regex = qr/(?<=\bRate: )(?:[5-9]\d{3}|[1-9]\d{4,})\b/p;
my $subst = '5000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";