$re = '/^(?!.*(Yes|No);$).*$/m';
$str = 'This line should be replaced.
But this should not, Yes;
Neither should this line No;
This line should be replaced also.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);