re = /^(?!.*(Yes|No);$).*$/m
str = 'This line should be replaced.
But this should not, Yes;
Neither should this line No;
This line should be replaced also.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end