import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<src_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?<dest_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?<src_port>\\d+)\\s+(?<dest_port>\\d+)";
final String string = "message=...w 2-APIS 0-External-1 tcp 10.0.12.13 40.126.31.8 55373 443 msg=\\\"HTTS...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}