const regex = /(?<src_ip>\d+\.\d+\.\d+\.\d+)\s+(?<dest_ip>\d+\.\d+\.\d+\.\d+)\s+(?<src_port>\d+)\s+(?<dest_port>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<src_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?<dest_ip>\\d+\\.\\d+\\.\\d+\\.\\d+)\\s+(?<src_port>\\d+)\\s+(?<dest_port>\\d+)', 'gm')
const str = `message=...w 2-APIS 0-External-1 tcp 10.0.12.13 40.126.31.8 55373 443 msg=\\"HTTS...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}