#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\s+:\s+((?:[A-Fa-f\d][A-Fa-f\d])+(?: (?:[A-Fa-f\d][A-Fa-f\d])+)*)\b"
Local $sString = " The second example wraps 7 octets of key data with a 192-bit KEK." & @CRLF & _
" KEK : 5840df6e29b02af1 ab493b705bf16ea1 ae8338f4dcc176a8" & @CRLF & _
" Key : 466f7250617369" & @CRLF & _
" Wrap : afbeb0f07dfbf541 9200f2ccb50bb24f" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" KEK : 5840df6e29b02af1 ab493b705bf16ea1 ae8338f4dcc176a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")