import re
regex = re.compile(r"(\w+)\s+:\s+((?:[A-Fa-f\d][A-Fa-f\d])+(?: (?:[A-Fa-f\d][A-Fa-f\d])+)*)\b", flags=re.MULTILINE)
test_str = (" The second example wraps 7 octets of key data with a 192-bit KEK.\n"
" KEK : 5840df6e29b02af1 ab493b705bf16ea1 ae8338f4dcc176a8\n"
" Key : 466f7250617369\n"
" Wrap : afbeb0f07dfbf541 9200f2ccb50bb24f\n\n\n"
" KEK : 5840df6e29b02af1 ab493b705bf16ea1 ae8338f4dcc176a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")