#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "1?\W*([2-9][0-8][0-9])\W*([2-9][0-9]{2})\W*([0-9]{4})"
Local $sString = "AlexCrawford@dayrep.com+1 (208) 264-9063" & @CRLF & _
"StefanijaNovosel@teleworm.us1 518 487 4865" & @CRLF & _
"someemail@me.comss(845) 858-7707" & @CRLF & _
"JakobCJakobsen@einrot.com+1 (845) 858-7707" & @CRLF & _
"johndoe@email.com1234567890" & @CRLF & _
"304-438-2648SandraCTaylor@dayrep.com" & @CRLF & _
"978-243-8596JuanPerez@teleworm.us" & @CRLF & _
"413-259-3637BuiQuynhChan@fleckens.hu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")