import re
regex = re.compile(r"1?\W*([2-9][0-8][0-9])\W*([2-9][0-9]{2})\W*([0-9]{4})")
test_str = ("AlexCrawford@dayrep.com+1 (208) 264-9063\n"
"StefanijaNovosel@teleworm.us1 518 487 4865\n"
"someemail@me.comss(845) 858-7707\n"
"JakobCJakobsen@einrot.com+1 (845) 858-7707\n"
"johndoe@email.com1234567890\n"
"304-438-2648SandraCTaylor@dayrep.com\n"
"978-243-8596JuanPerez@teleworm.us\n"
"413-259-3637BuiQuynhChan@fleckens.hu")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")