using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:[^'\""]*(?:'|\"")[^'\""]*(?:'|\""))*[^'\""]*$)\s+";
string substitution = @" ";
string input = @"Name is :- 'Nipun V Shah ' with TT (""table tennis"")";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}