re = /(?=(?:[^'\"]*(?:'|\")[^'\"]*(?:'|\"))*[^'\"]*$)\s+/x
str = 'Name is :- \'Nipun V Shah \' with TT ("table tennis")'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result