$re = '/(?-i)(?:^(?:Mc)?[A-Z]+(?:[ -][A-Z]+)*|\G(?!^)[A-Z][a-z]+(?:-[A-Z][a-z]+)*|\d{2}\.\d{2}\.\d{4})\K -?\h*/';
$str = 'ADLINGTON-JONES Robin Jacob Sebastian - 15.02.1999 - B
AFZAL Kiera - 25.04.2000 - B
AHMED Nisar Abu Ben Adhem - 16.08.2002 - C
AIRE-DEANE Christopher-James - 06.01.1997 - B
AL-MISRI Yaqoob - 23.07.2004 - C
ASTER Lily-May - 01.04.2010 - B
McQUEEN Stephen - 02.02.2001 - A';
$subst = "¬";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;