#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?(1)(?|(#\1)|(#))\d+)+$"
Local $sString = "#123" & @CRLF & _
"#12##235" & @CRLF & _
"#1234##12###368" & @CRLF & _
"#1234##12###368####22235#####723356" & @CRLF & _
"" & @CRLF & _
"##123" & @CRLF & _
"#123###456" & @CRLF & _
"#123##456##789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")