re = /^(?(1)(?|(#\1)|(#))\d+)+$/m
str = '#123
#12##235
#1234##12###368
#1234##12###368####22235#####723356
##123
#123###456
#123##456##789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end