package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[\d-]+\b`)
var str = `K9908098F, G2342D34324/ 234234323, 234-234-234; R324234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}