re = /\b[\d-]+\b/
str = 'K9908098F, G2342D34324/ 234234323, 234-234-234; R324234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end