$re = '/--START\h*\R\s*(.*?)\h*\R\s*--END/m';
$str = '--START
select * from table;
--END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);