re = /--START\h*\R\s*(.*?)\h*\R\s*--END/m
str = '--START
select * from table;
--END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end