$re = '/S8(?!\+)/mi';
$str = 'testS8+test
tests8test
S8 test
test S8 test
test S8+ test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);