re = /S8(?!\+)/mi
str = 'testS8+test
tests8test
S8 test
test S8 test
test S8+ test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end