package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+(?:\.[0-9]+)?`)
var str = `1234*(5600-230.831)+1234.56/8456123*25%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}