$re = '/[0-9]+(?:\.[0-9]+)?/m';
$str = '1234*(5600-230.831)+1234.56/8456123*25%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);