const regex = new RegExp('((\\b\\p{Upper}\\w+)|(\\b\\p{Upper}\\w{1,5}\\.)) ?( ((\\b\\p{Lower}{1,6})|(\\b\\p{Upper}\\w+)|((\\b\\p{Upper}\\w{1,5}\\.)))){0,4} v\\.? ((\\b\\p{Upper}\\w+)|(\\b\\p{Upper}\\w{1,5}\\.)) ?( ((\\b\\p{Lower}{1,6})|(\\b\\p{Upper}\\w+)|((\\b\\p{Upper}\\w{1,5}\\.)))){0,4}', 'mg')
const str = `This is not a case. But this is: Riley v. California. And riley v. california also isn't.
Riley v. California and Mapp v. Ohio "United Zinc & Chemical Co. v. Britt" should all count, but not MAPP V. OHIO!
Both R.A. Peacock v. Lubbock Compress Company and Battalla v. State of New York have complex names.
But also, Craggan v. IKEA USA and this Case: Edwards v. Honeywell, Inc..`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}