use strict;
my $str = 'This is not a case. But this is: Riley v. California. And riley v. california also isn\'t.
Riley v. California and Mapp v. Ohio "United Zinc & Chemical Co. v. Britt" should all count, but not MAPP V. OHIO!
Both R.A. Peacock v. Lubbock Compress Company and Battalla v. State of New York have complex names.
But also, Craggan v. IKEA USA and this Case: Edwards v. Honeywell, Inc..';
my $regex = qr/((\b\p{Upper}\w+)|(\b\p{Upper}\w{1,5}\.)) ?( ((\b\p{Lower}{1,6})|(\b\p{Upper}\w+)|((\b\p{Upper}\w{1,5}\.)))){0,4} v\.? ((\b\p{Upper}\w+)|(\b\p{Upper}\w{1,5}\.)) ?( ((\b\p{Lower}{1,6})|(\b\p{Upper}\w+)|((\b\p{Upper}\w{1,5}\.)))){0,4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}