$re = '/(.*?)=(.*?)/m';
$str = 'self.theta = theta
self.alpha = alpha
self.beta = beta';
$subst = "\2 = \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;