import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{1,254}$)(?=.{1,64}@)[-!#$%&'*+/0-9=?A-Z^_`a-z\\{|\\}~]+(\\.[-!#$%&'*+/0-9=?A-Z^_`a-z\\{|\\}~]+)*@[A-Za-z0-9]([A-Za-z0-9-]{0,61}[A-Za-z0-9])?(\\.[A-Za-z0-9]([A-Za-z0-9-]{0,61}[A-Za-z0-9])?)*$";
final String string = "polo+1111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111@foo.com\n"
+ "polo+11111111111111111111111111111111111111111111111111111111111@foo.com\n"
+ "polo111111111111111111111111111111111111111111111111111111111111@foo.com\n"
+ "polo1111111111111111111111111111111111111111111111111111111111112@foo.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}