re = /^(?=.{1,254}$)(?=.{1,64}@)[-!#$%&'*+\/0-9=?A-Z^_`a-z{|}~]+(\.[-!#$%&'*+\/0-9=?A-Z^_`a-z{|}~]+)*@[A-Za-z0-9]([A-Za-z0-9-]{0,61}[A-Za-z0-9])?(\.[A-Za-z0-9]([A-Za-z0-9-]{0,61}[A-Za-z0-9])?)*$/m
str = 'polo+1111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111@foo.com
polo+11111111111111111111111111111111111111111111111111111111111@foo.com
polo111111111111111111111111111111111111111111111111111111111111@foo.com
polo1111111111111111111111111111111111111111111111111111111111112@foo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end