$re = '/(?<!\d|\.)((\d\.\d|\d)(?!\d|\.\d)[^\d,;.]+?listening)/m';
$str = 'ielts 6. overall 6.5; reading 6; writing 6; speaking 6.6 listening 6. for other english language proficiency tests and scores approved for uq listening 6.6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);